Project Navigator: Empowering your ElementsPart |1
Written by: Bill Knittle, Synergis Building Solutions Engineer

In my previous article | overlooked one small technical issue. This process only worksin
Architectural Desktop (ADT) 2007 and AutoCAD Architecture (ACA) 2008. AutoCAD
2007 introduced the External References Palette which replaced the obsol ete External
References dialog box of previous versions of AutoCAD and ADT. This upgrade
included the lower pane which allows usersto view a preview or property details of an
external reference. Therefore, this workflow will not work in ADT versions 06 and
earlier.

Now that | cleared the air, we can pick up where we left off in the previous article,
documenting the model. For those of uswho are veterans of “Projects’ the project
workflow is straight forward. The project’ strail of external referencing normally looks
like the diagram in Figure 1.
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To understand the tasks that lie ahead, it isimportant to understand the purpose for each
type of drawing. The Elements and Constructs contain the model objects only. Views
contain referenced Constructs and annotation. Sheets contain referenced Views and are
utilized for plotting.

The problem that we will encounter involves how to deal with the intelligence or
Property Data in each object of the repeating Element. An object’ s Property Datais
comprised of Property Sets. Each Property Set contains multiple Property Definitions.
Property Sets can be applied a majority of ways. The typical method involves the use of a
Tag tool. The datais then extracted by the Schedule Table designated to that object. The
typical trail of applying and reporting Property Datalooks like the diagram in Figure 2.
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This process works great when an object isa single instancein amodel. When it is
redundant, it involves a small detour from the project workflow process. Here we go!

Step 1: Making the Detour

Create an intelligent Element
1. Select the Construct tab on the Project Navigator.
2. Double-click the Typ Dorm Room Lt element in the Project Navigator to open
it.
3. Switch the workspace to Document on the W or kspaces tool bar.
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4. Select the Room Tag — Project Based tool on the Tags tab of the Palette Set.
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Select the large diagonal hatch pattern of the space object.
Enter the values to the Property Definitionsin the Edit Property Set Data
dialog box under RoomFinishObjects. Figure 4
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Click the OK button to continue to the next room.
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8. Repeat the process for the small closet space.
9. Click the Enter key or Spacebar to exit the command. Figure 5
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10. Select the Door Tag — Project Based tool on the Tagstab of the Palette Set.

11. Select the bi-fold door into the closet and place the tag.

12. Clear the value for Number Suffix in the Edit Property Set Data dialog box.
Figure 6
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14. Select the bi-fold door object.




15. Select the Property Data L ocation grip (star shape).
16. Drag the grip into the closet to associate the door to the closet. Figure 8
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17. Select the larger space.
18. Enter Dorm for the Name property in the Properties Palette.
19. Repeat steps 17 and 18 to name the small space CL. Figure 9
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20. Select the tags and delete them.
21. Save and close the Typ Dorm Room Lt element.
22. Repeat steps 2 thru 21 for the Typ Dorm Room Rt element.

Step 2: Create a General View of the First Floor

Createa View to annotate the First Floor

Select the View tab on the Project Navigator .

Select the Views category.

Click the New View button.

Select the General View radio button in the Add View dialog box.
Click the OK button to begin the Add General View wizard. Figure 10
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A Genera View typeis meant for
general use. A different drawing
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1. Enter A-FPO1 for Name and First Floor View for Description.
2. Click the Next button to move to the next page.

3. Click the check box for Level 1totell ADT / ACA what construct drawings to

reference into the View.
4. Click the Next button to move to the next page.
5. Verify that the 01 Shell Walls construct is checked.

6. Click the Finish button to complete the wizard. Figure 11
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Set up the View

1. Double-click the new view A-FPO1 in the Project Navigator to open it.
2. Verify that the right constructs are referenced in. Figure 12
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Createthe View's M odel Space View

Project Tip!

Use ADT /ACA’sCadlout Tag
Tool buttons and View Wizards to
properly reference drawing files.
Abstain from using Insert>DWG
Referencein “Projects.”

1. Right-click on the view A-FPOL in the Project Navigator to open the Context
Menu.
2. Select New Model Space View from the menu.
3. Inthe Add M odel Space View dialog box, enter First Floor Plan for the Name
and select 1/4” = 1'-0" from the Scalelist.
4. Click the Define View Window button. To create a viewport boundary around
the model. Figure 13
b 4 f Add Model Space View x
5 viens e AR o Ve e
£ e o e e e et Space
Regenerate game. First Floor Plan _’&
ham Show External References... fs,:;”ptmn T
s r— 3. 4.
:
E E Mew Model Space Yiew. ..
— 2 Cancel Help
£
= Copy
7 Folder: % Py PrOJeCt T| p|
. 3 - ADT / ACA uses the Sheet Set
E eTransmit. .. “ = funCt'onaI |ty Of AUIOCAD
" Properties... gg Therefore, viewport boundaries are
- [(eleB v = m “ Figure 13 created in Model Space.
E




5. Drag a selection window around the model to create the viewport boundary.
6. Inthe Add Model Space View dialog box, click the OK button. Figure 14
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Double-click the nested model space view First Floor Plan in the Project
Navigator to openit. Thiswill display atemporary window indicating the name
and boundary of the viewport. Thiswill also set the Annotation Scale on the
Drawing Status Bar to the model space view’s scale. Figure 15
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Select the Callouts tab on the Palette Set.

Select the Title Mark tool to add atitle mark to the model space view.

Specify two endpoints to draw the title mark within the red boundary of the
viewport. Note that the fields of thetitle mark symbol have filled themselves out
with the name and scale of the model space view. Figurele6.
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5. Select the Tagstab on the Palette Set.
6. Select the Room Tag — Project Based tool.
7. Select the large space of the lower-left room.
8. The Edit Property Set Data dialog box will open. Click the OK button to
continue because you will notice that the values are already there. Figure 17
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9. Select the closet of that room and click the OK button to continue.

10. Repeat steps 7 thru 9 for the next three dorm rooms and their closets.

11. Now, select the long corridor.

12. Enter the values for CeilingM aterial, EastM aterial, Floor M aterial, North
Material, South Material, and West Material.

13. Finally, select the remaining room and fill out the values mentioned in the
previous step.

14. Click the blue hyperlink on the Exter nal Refer ence balloon notification.
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Renumbering the Rooms

1.
2.
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Select the Renumber Datatool on the Palette Set.

Click the OK button to accept SpaceObjects as the Property Set and I ncrement
asthe Property in the Data Renumber dialog box.

Select the Room Tag in the large space of the first room.

Select that room'’ s closet tag.

Select the Room Tag in the large space of the second room.

Select that room'’ s closet tag.

Select the Room Tag in the large space of the third room.

Select that room'’ s closet tag.

Select the Room Tag in the large space of the fourth room.

10 Select that room'’ s closet tag.

11. Select the corridor’ stag.

12. Select the remaining room’ s tag.

13. Click the Enter or Spacebar key to exit the command. Figure 19
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14. Click the blue hyperlink on the External Refer ence balloon notification when it
appears.
Tag the Doors

1. Select the Door Tag — Project Based tool on the Palette Set.
2. Tag the entry door into room 101.
3. Clear the“A” value for Door Suffix in the Edit Property Set Data dialog box.
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4. Click the OK button to continue. Figure 20
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5. Right-click and select M ultiple in the Context M enu.
6. Drag aselection window around the bottom four rooms. Figure 21
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7. Click the Enter or Spacebar key to exit the command.
8. Click the No button in the warning dialog box to avoid re-tagging the same door.
Figure 22
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9. Clear the Number Suffix property in the Edit Property Set Data dialog box
10. Click the OK button to see the results.



11. Delete the four window tags. (The DoorObjects Property Set appliesto
Door/Window Assemblies aswell.) Figure 23
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12. Tag the far right double-door and allow the Number Suffix to remainas“A” in
the Edit Property Set Data dialog window.

13. Click the OK button to continue.

14. Tag the double-door directly left of that one.

15. Enter “B” for the Number Suffix in the Edit Property Set Data dialog window.

16. Click the OK button to continue.

17. Tag the far left double-door and clear the Number Suffix value.

18. Click the Enter or Spacebar key to exit the command. Figure 24
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Repair Door Tags
1. Select the referenced construct and right-click.
2. Select Edit Xref in-place... in the Context Menu. Figure 25
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3. Select the OK button in the Reference Edit dialog box.
4. Select the far right double-door. Figure 26
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5. Select the Property Data L ocation grip on the door object.
6. Drag it into the space, |eft of the door.
7. Select the Save back changesto refer ence button on the Refedit toolbar.
8. Click the OK button on the warning dialog box. Figure 27
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Repair the Room Tags

1. Select the referenced construct and right-click.
2. Select Edit Xref in-place... in the Context Menu. Flgure 28
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3. Select the OK bhutton in the Reference Edit dialog box.

4. Select thelong corridor space.

5. Enter Corridor for the Name property in the Design tab of the Properties
palette. (Note that these spaces are the Standard style. If you use predefined

space styles, you may need to select a name from thelist.)

Refedit

[ |01 Shellwalls W T by

General ~
Description =)
Layer W $0$a-Area..,

7z

Offset ba... By style 5
Calculatio... =) *NONE™ ° A
=1 SpacefZon... /v//

Figure 29

6. Desdlect the corridor space and select the square space at the far right.

7. Rename this space Vest. in the Properties palette.

8. Select the Save changes back to reference... button on the Refedit toolbar.
9. Click the OK button in the warning dialog box. Figure 30
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10. Continue annotating the view as usual by adding text, dimensions, callouts,
etc...

11. Create the views for the remaining floors and repeat this process..

12. Freeze the * Spce layersin each view. (Layer property filters work great for
this.)




Step 3: Finishing thejob, creating the plotting Sheets

Create a Sheet

NogkrwdrE

palette. Figure 31

Sheet title:

First Floor Plan

Select the Sheetstab on the Project Navigator palette.
Select the Architectural subset.

Select the Add Sheet button at the base of the Project Navigator palette.
Enter A100 for the Number.
Enter First Floor Plan for the Sheet title.

Click the OK button on the New Sheet dialog box.
Double-click the new sheet A100 First Floor Plan in the Project Navigator

Project

File name: | 4100 First Floor Plan

Folder path: | C:iDocuments and Settingsiill. KnittleiMy Documents) AutodeskiMy Projects

Sheet template: | Arch D {24 x 36){C:\Documents and Settingshall Usersiapplication Datalaut
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1. Select the Viewstab on the Project Navigator palette.
2. Expand the view A-FPO1 to see the First Floor Plan model space view.
3. Pressand drag the First Floor Plan into the sheet. Figure 32
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Browse Property Data

Door Schedule

Doaor Schedule Project
EBased

Wall Schedule

Click to place the model space view on the sheet.

Select the Scheduling tab on the Palette Set.

Select the M ore Scheduling Tools tool to open the Content Browser. (In
ADT 07, you must go to Window> Content Browser>Documentation Tool
Catalog — Imperial>Scheduling Tables)

Press and drag the i-dr op symbol of Room Finish Schedule Project Based
tag into the sheet.

Click the Enter or Spacebar key to schedule an externa reference drawing.
Figure 33
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0.

Click to place the schedule header in the sheet.

10. Click the Enter or Spacebar key to scale the schedule appropriately. Figure

Figure 34




Adjust the Schedule Table's Properties
1. Select the schedule table.
2. Select Yesfrom the drop down for the property Schedule exter nal drawing.
3. Select the Browse option in the drop down for the property Exter nal
drawing.
4. Browseto <project name>/Views/ and select A-FP01.dwg. Figure 35
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5. Right-click while the table is selected to open the Context M enu.
6. Select Update Schedule Table from the Context Menu.
7. Thetableisupdated. Figure 36
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101 DORM (i3 GWE[GWH|GWH| SWB | ATC B—5" -
0z [ CF GWE [GWH| GWH| GWB | ATC i) —
03 DORM P GWB[GWH|CWH| GWB | ATC 86 -
04 cL i3 GWE [ GWH|CWH| SWB | ATC 55" -
i DORM P GWE [ GWH | GWH| GWB | ATC B —
06 CL P GWB[GWH|CWH| EWB | ATC 86 -
07 DORM i3 GWE [ GWH|CWH| SWB|  ATC 85" -
08 cL CPT___|GWE|GWH|GWH|GWB | ATC B -
08 CORRIDOR | GWE _ [GWB[GWH|CWH|CWB| ATC 86" -
10 WEST. GWE__ |GWE[GWH[GWH[SWB|  ATC B—6" —

8. Repeat the processto create the additional sheets for the additional plans.

WALLS CEILING
ROOM NO | NAME | FLOOR NTsTE W MATL IHEIGH NOTES
201 DORM CPT__ |GWE|GWB|GWB|GWB|  ATC -6 --
202 CL. CPT__ |GWB|CWB|CWB| GWE|  ATC 86" -
203 DORM CFT__ |GWB|GHB|GWB| GWE|  ATC 86 --
204 CL CF GWB|GWB|GWB| GWB | ATC B -
205 DORM P GWB[CWB|GWB[ GWB | ATC g6 -
208 L CP GWE [ GWB| GWEB| GMB|__ATC g-6 —
207 DORM CF GWB [ GWE|GWB| GWB | ATC 86" -
208 CL. CPT___|GWE|GWB|GWB| GWB| ATC 86 -
209 CORRIDOR | CPT__ | GWB|GWB|GWB| GHE] ATC i —




Each schedule on each sheet should show the appropriate information for that floor plan.
The finish information is derived from the elements therefore, all the information is
consistent. If aroom needs different finishes that makes it unique. Y ou will need to make
it part of the construct. If you need more scheduling control, investigate the use of
classificationsto filter similar objects based on classification. Happy documenting!



